Jump to content

  •  

Problem executing the ol linux binaries


9 replies to this topic

#1 teta1

teta1

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 December 2012 - 10:52 AM

Both the 32bit and 64bit binaries starts up and shows briefly the loading screen but then abort with the following:

ol.x86-64.linux.bin: io/cal3d_io_wrapper.cpp:261: int CalCoreModel_ELLoadCoreAnimation(CalCoreModel*, const char*, float): Assertion `self' failed.


I can use the regular EL client to play the game so it's not a problem in that sense. Is there perhaps some special precautions I should take concerning cal3d before attempting to launch the game?

I cant get the #ver of the build but it was packaged  on 24 of October and dowloaded from the Downloads section of the Other-Life site.

#2 groomsh

groomsh

    Member

  • Full Member
  • PipPip
  • 295 posts

Posted 03 December 2012 - 02:13 AM

Could it be that you miss some data files ?

#3 Bat17

Bat17

    Member

  • Full Member
  • PipPip
  • 240 posts

Posted 25 August 2013 - 07:07 AM

I am having the same issue with the download installed in Mint 14, curiously I did not get the error when installing to Puppy so I assume it is some sort of library issue, but not sure.

The EL download installs and runs OK, ( or at least for the 30 seconds I stayed logged in ) :-)

Bat17

#4 groomsh

groomsh

    Member

  • Full Member
  • PipPip
  • 295 posts

Posted 27 August 2013 - 01:46 AM

Hmm try doing ldd on ol binary and check whether there is a missing library

#5 Guest_Mageia_*

Guest_Mageia_*
  • Guests

Posted 08 September 2013 - 12:06 PM

hello,

im new here and have the same problem like teta1.

after using the ldd-check on the bin-file i got these output:

~/Otherlife/ol_linux$ ldd ol.x86-64.linux.bin
linux-vdso.so.1 =>  (0x00007fff199ff000)
libSDL-1.2.so.0 => /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0 (0x00007f6446c68000)
libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f644690c000)
libSDL_net-1.2.so.0 => /usr/lib/x86_64-linux-gnu/libSDL_net-1.2.so.0 (0x00007f6446706000)
libSDL_image-1.2.so.0 => /usr/lib/x86_64-linux-gnu/libSDL_image-1.2.so.0 (0x00007f64464e8000)
libopenal.so.1 => /usr/lib/x86_64-linux-gnu/libopenal.so.1 (0x00007f644628f000)
libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1 (0x00007f6445f71000)
libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f6445cf2000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f64459f6000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f64457de000)
libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f64455b8000)
libvorbisfile.so.3 => /usr/lib/x86_64-linux-gnu/libvorbisfile.so.3 (0x00007f64453b0000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f6445199000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6444dda000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f6444aa0000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f6444882000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f644457f000)
libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007f6444295000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f6444090000)
libpulse-simple.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-simple.so.0 (0x00007f6443e8c000)
libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f6443c44000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f6443a31000)
libcaca.so.0 => /usr/lib/x86_64-linux-gnu/libcaca.so.0 (0x00007f6443764000)
liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f6443542000)
libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f64432f0000)
libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f644307f000)
libwebp.so.2 => /usr/lib/x86_64-linux-gnu/libwebp.so.2 (0x00007f6442e47000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f6442c3e000)
libnvidia-tls.so.304.88 => /usr/lib/nvidia-current/tls/libnvidia-tls.so.304.88 (0x00007f6442a3b000)
libnvidia-glcore.so.304.88 => /usr/lib/nvidia-current/libnvidia-glcore.so.304.88 (0x00007f6440651000)
libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f6440423000)
libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f644021c000)
/lib64/ld-linux-x86-64.so.2 (0x00007f6446f1f000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f643fffd000)
libpulsecommon-2.1.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-2.1.so (0x00007f643fda0000)
libjson.so.0 => /usr/lib/x86_64-linux-gnu/libjson.so.0 (0x00007f643fb96000)
libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f643f952000)
libslang.so.2 => /lib/x86_64-linux-gnu/libslang.so.2 (0x00007f643f5c2000)
libncursesw.so.5 => /lib/x86_64-linux-gnu/libncursesw.so.5 (0x00007f643f394000)
libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007f643f16c000)
libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007f643ef5e000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f643ed59000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f643eb53000)
libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f643e948000)
libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f643e6e2000)
libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f643e4dc000)
libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f643e2c1000)
libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f643e075000)
libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f643dba5000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f643d989000)

Question is: Which file is missing?

Greetings

Mageia

#6 themuntdregger

themuntdregger

    Advanced Member

  • Full Member
  • PipPipPip
  • 736 posts

Posted 08 September 2013 - 05:55 PM

I suspect it may be libcal3d

#7 Guest_Mageia_*

Guest_Mageia_*
  • Guests

Posted 09 September 2013 - 12:48 AM

hmmm.... i installed libcal3d yesterday.

but still i get these comment after trying to start ol:

~/Otherlife/ol_linux$ ./ol.x86-64.linux.bin
ol.x86-64.linux.bin: io/cal3d_io_wrapper.cpp:261: int CalCoreModel_ELLoadCoreAnimation(CalCoreModel*, const char*, float): Assertion `self' failed.
Abgebrochen (Speicherabzug geschrieben)

#8 themuntdregger

themuntdregger

    Advanced Member

  • Full Member
  • PipPipPip
  • 736 posts

Posted 10 September 2013 - 01:10 PM

Sorry for the long wait.

Other things that i've seen cause that particular error are problems with graphic drivers, opengl and libxml. Can you tell me what video card and distro you are running ?

#9 Guest_Mageia_*

Guest_Mageia_*
  • Guests

Posted 11 September 2013 - 01:39 AM

hello themuntdregger,

i use ubuntu 12.10 64bit and my graphiccard is a geforce gt620 1024mb. at the moment i use the driver-version 304.88

could be that i should install the newest one, or?

#10 Guest_Mageia_*

Guest_Mageia_*
  • Guests

Posted 13 September 2013 - 06:03 AM

so, after trying to install the game alot i gave up and took the windows-client! that one works fine under wine for me!  :)

greetings

mageia

ps: why cant i write a post when i logged in?  O_O



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users