Jump to content

  •  

Experimental AU Proxy


  • Please log in to reply
16 replies to this topic

#1 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 12:02 PM

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

PS Only people in or near AU will benefit. Others will see #ping go up by about 400ms or so, but can help in testing it works for them or tweak the instructions.

#2 Zian

Zian

    Member

  • Full Member
  • PipPip
  • 454 posts
  • LocationCanada

Posted 20 July 2019 - 01:34 PM

View PostLearner, on 20 July 2019 - 12:02 PM, said:

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

Nothing happens after clicking on new shortcut. :(

Z

See my setup below;

edited servers.LST file

# server.lst - Server list configuration file
# Note: Any amount of whitespace is allowed and # marks a comment from that point until EOL
# ID        Config Dir      Address                 Port    Description (to be used for server selection window)
main other-life      game.other-life.com     443     Other-life (port 443)
au          other-life    au.other-life.com  443  Other-life (port 443)
main-2000 other-life      game.other-life.com     2000    Other-life (port 2000)
eu other-life      eu.other-life.com       443     Other-life (EU proxy)
stage       other-life      stage.other-life.com    443     Stage server (proxy)
test        test            test.other-life.com     443     Test server (proxy)
maps        test            maps.other-life.com     2000    Maps server (direct)
dev         test            dev.other-life.com      443     Dev server (proxy)
proxy       other-life      proxy.other-life.com    443     Other-life (proxy)
proxy1      other-life      proxy1.other-life.com   443     Other-life (proxy)
proxy2      other-life      proxy2.other-life.com   443     Other-life (proxy)

Shortcut Target;

"C:\Program Files (x86)\Other-Life\ol.exe" au

Hope this helps.

Z

#3 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 01:34 PM

View PostZian, on 20 July 2019 - 01:29 PM, said:

View PostLearner, on 20 July 2019 - 12:02 PM, said:

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

Nothing happens after clicking on new shortcut. Posted Image

Z
Then you must have done something wrong ... I did it and was able to connect without an almost 400ms #ping through the new box. Double check what you put into servers.lst since a typo can mess things up. Do NOT add it to the end (there is a dumb limit on how many lines server.lst will load in the client)

#4 Zian

Zian

    Member

  • Full Member
  • PipPip
  • 454 posts
  • LocationCanada

Posted 20 July 2019 - 01:36 PM

View PostLearner, on 20 July 2019 - 01:34 PM, said:

View PostZian, on 20 July 2019 - 01:29 PM, said:

View PostLearner, on 20 July 2019 - 12:02 PM, said:

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

Nothing happens after clicking on new shortcut. Posted Image

Z
Then you must have done something wrong ... I did it and was able to connect without an almost 400ms #ping through the new box. Double check what you put into servers.lst since a typo can mess things up. Do NOT add it to the end (there is a dumb limit on how many lines server.lst will load in the client)

edited my original post

#5 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 01:41 PM

View PostZian, on 20 July 2019 - 01:36 PM, said:

View PostLearner, on 20 July 2019 - 01:34 PM, said:

View PostZian, on 20 July 2019 - 01:29 PM, said:

View PostLearner, on 20 July 2019 - 12:02 PM, said:

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

Nothing happens after clicking on new shortcut. Posted Image

Z
Then you must have done something wrong ... I did it and was able to connect without an almost 400ms #ping through the new box. Double check what you put into servers.lst since a typo can mess things up. Do NOT add it to the end (there is a dumb limit on how many lines server.lst will load in the client)

edited my original post
That should work as long as the shortcut you uses the new au definition.

#6 Zian

Zian

    Member

  • Full Member
  • PipPip
  • 454 posts
  • LocationCanada

Posted 20 July 2019 - 01:44 PM

View PostLearner, on 20 July 2019 - 01:41 PM, said:

View PostZian, on 20 July 2019 - 01:36 PM, said:

View PostLearner, on 20 July 2019 - 01:34 PM, said:

View PostZian, on 20 July 2019 - 01:29 PM, said:

View PostLearner, on 20 July 2019 - 12:02 PM, said:

I'm setting up an experimental OL Proxy for AU in Sydney. Currently this is a low cost low performance system, but we need to test to see if the different routing it causes improves AU #ping & lag

Instructions for use:
* Edit your servers.lst to add this line after main: au   other-life   au.other-life.com 443 Other-life (port 443)
* Make a new shortcut (similar to how you connect to test), but specify au instead of test
* Try the old & new connections repeatedly, comparing #ping information and how it feels between the two
* Post your feedback here!

Nothing happens after clicking on new shortcut. Posted Image

Z
Then you must have done something wrong ... I did it and was able to connect without an almost 400ms #ping through the new box. Double check what you put into servers.lst since a typo can mess things up. Do NOT add it to the end (there is a dumb limit on how many lines server.lst will load in the client)

edited my original post
That should work as long as the shortcut you uses the new au definition.

Yep - I show my new Shortcut which uses the au designation - see my original post

#7 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 02:06 PM

I have to ask the obvious questions, since I did the same thing and it worked properly for me.

#8 Zian

Zian

    Member

  • Full Member
  • PipPip
  • 454 posts
  • LocationCanada

Posted 20 July 2019 - 02:40 PM

After clearing a couple of lines in the servers.LST file I got this working;

au server results;

Server latency: 66 ms
Server latency: 79 ms
Server latency: 1212 ms
Server latency: 95 ms
Server latency: 96 ms
Server latency: 99 ms
Server latency: 100 ms
Server latency: 88 ms
Server latency: 1586 ms
Server latency: 127 ms
Server latency: 80 ms

main server results;


Server latency: 100 ms
Server latency: 120 ms
skullpants: hi
Server latency: 769 ms
Server latency: 738 ms
Server latency: 87 ms
Server latency: 301 ms
Server latency: 251 ms
Server latency: 1704 ms
Server latency: 92 ms
Server latency: 98 ms
Server latency: 143 ms
Server latency: 2465 ms


I'm lagging alot last couple of days :(


Regards
Z

#9 Zian

Zian

    Member

  • Full Member
  • PipPip
  • 454 posts
  • LocationCanada

Posted 20 July 2019 - 02:49 PM

Sorry - i messed up...fogot to change my au shortcut back to au;

new results;

Server latency: 1925 ms
Server latency: 2749 ms
Server latency: 1155 ms
Server latency: 502 ms
Server latency: 486 ms
Server latency: 3103 ms
Server latency: 653 ms
Server latency: 514 ms
Server latency: 575 ms
Server latency: 2157 ms

#10 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 02:51 PM

View PostZian, on 20 July 2019 - 02:49 PM, said:

Sorry - i messed up...fogot to change my au shortcut back to au;

new results;

Server latency: 1925 ms
Server latency: 2749 ms
Server latency: 1155 ms
Server latency: 502 ms
Server latency: 486 ms
Server latency: 3103 ms
Server latency: 653 ms
Server latency: 514 ms
Server latency: 575 ms
Server latency: 2157 ms
Hence why only AU players have a chance to benefit at all.

#11 Warlock

Warlock

    Advanced Member

  • Full Member
  • PipPipPip
  • 600 posts
  • LocationLuton-London

Posted 20 July 2019 - 04:32 PM

Edited - didnt read fully before commenting. What is the limit, 10?

#12 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 20 July 2019 - 04:52 PM

View PostWarlock, on 20 July 2019 - 04:32 PM, said:

Edited - didnt read fully before commenting. What is the limit, 10?
Seems like 10 usable ... and it seems to count comments! Will have to talk to Bluap to fix things.

#13 CoduX

CoduX

    Advanced Member

  • Full Member
  • PipPipPip
  • 1201 posts
  • LocationLand Down Under

Posted 20 July 2019 - 10:35 PM

this...this is beautiful! My MS went from 210ish to 4ms Posted Image

#14 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 21 July 2019 - 03:36 AM

View PostCoduX, on 20 July 2019 - 10:35 PM, said:

this...this is beautiful! My MS went from 210ish to 4ms Posted Image
That's only the distance between you and the proxy, what difference is there between #ping on the old vs the new? That is what matters.

#15 ohmygod

ohmygod

    Advanced Member

  • Full Member
  • PipPipPip
  • 591 posts
  • Locationaustralia

Posted 30 July 2019 - 01:48 AM

I messed up my test server short cut now and when i change au to test it just logs onto the au server regardless

#16 Learner

Learner

    God

  • Administrators
  • 2805 posts

Posted 30 July 2019 - 02:29 AM

View Postohmygod, on 30 July 2019 - 01:48 AM, said:

I messed up my test server short cut now and when i change au to test it just logs onto the au server regardless
Don't forget to also check your servers.lst file in case you changes test to access au instead.

#17 ohmygod

ohmygod

    Advanced Member

  • Full Member
  • PipPipPip
  • 591 posts
  • Locationaustralia

Posted 30 July 2019 - 03:01 AM

that was the problem. works now ty




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users